Back to overview
Downtime

Spectrum Premium is down

Jul 31, 2024 at 04:10pm UTC

Resolved
Jul 31, 2024 at 04:20pm UTC

Spectrum Premium is back online.

Created
Jul 31, 2024 at 04:10pm UTC

We acknowledged the issue and we are fixing it.