Back to overview
Maintenance

Website Down

Feb 16, 2026 at 07:15pm UTC  –  Feb 16, 2026 at 07:56pm UTC
Affected services
Spectrum Website

Resolved
Feb 16, 2026 at 07:56pm UTC

We finished early. Everything operational again.

Created
Feb 16, 2026 at 07:15pm UTC

Website Works, will be down temporarily.